本文作者:大道老师

通达信斐波那契财务主图指标

大道老师 6个月前 ( 05-01 ) 2244 抢沙发
通达信斐波那契财务主图指标摘要:   公式如下:MA144:MA(C,144),DOTLINE,COLORRED;MA233:MA(C,200),DOTLINE,COLORBB48AF;{高抛低...

 


通达信斐波那契财务主图指标  第1张

通达信斐波那契财务主图指标  第2张

 

公式如下:

MA144:MA(C,144),DOTLINE,COLORRED;
MA233:MA(C,200),DOTLINE,COLORBB48AF;
{高抛低吸}
重:(2*C+H+L)/4,COLOR00FFFF,LINETHICK0;
SJ:=WMA((重-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
DRAWTEXT(CROSS(SJ,ZJ) AND SJ<30,L-0.1,'←低吸'),COLOR00FF00;
DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,H+0.1,'←高抛'),COLOR0077FF;
{板块}
所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT('【行业】',HYBLOCK),STRCAT('【地域】',DYBLOCK)),STRCAT('【概念】',GNBLOCK)));
{业绩综合}
市盈率:=STRCAT('【市盈率】',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT('【市销率】',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT('【市净率】',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT('【净资收益率】',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT('【毛利率】',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT('【净利润率】',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT('【主营利润率】',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
未分利润:=STRCAT(STRCAT('【未分利润】',CON2STR(FINANCE(32)/1,2)),'元/股');
公积金:=STRCAT(STRCAT('【公积金】',CON2STR(FINANCE(18)/1,2)),'元/股');
当前业绩:=STRCAT('【当前业绩】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市销率,市净率),净资收益率),毛利率),净利润率),主营利润率),未分利润),公积金));
{财务分折}
现金流:=STRCAT(STRCAT('【现金流】',CON2STR(FINANCE(25)/100000000,2)),'亿');
流动比率:=STRCAT('【流动比率】',CON2STR(FINANCE(11)/FINANCE(15),2));
速动比率:=STRCAT('【速动比率】',CON2STR((FINANCE(11)-FINANCE(27))/FINANCE(15),2));
XA1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
XA2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
XA3:=FINANCE(23)/FINANCE(10)*3.3;
XA4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
XA5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=XA1+XA2+XA3+XA4+XA5;
{ GUPANG.COM 股-旁-网_通达信股票指标公式}
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.

剩余50%内容付费后可查看
文章版权及转载声明

作者:大道老师本文地址:http://www.dadaols.com/?id=832发布于 6个月前 ( 05-01 )
文章转载或复制请以超链接形式并注明出处123股票学习网

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

阅读
分享

发表评论

快捷回复:

评论列表 (暂无评论,2244人围观)参与讨论

还没有评论,来说两句吧...