本文作者:大道老师

黄金分割线指标1.0

大道老师 5个月前 ( 02-26 ) 2936 抢沙发
双11
黄金分割线指标1.0摘要: 斐波那契回调线也叫黄金分割线,在技术分析中经常使用,用来测算一段行情的理论幅度,以寻找相应的支撑和阻力。黄金分割线是一种古老的数学方法,黄金分割的创始人是古希腊的毕达哥拉斯,他在当...


1111.png 黄金分割线指标1.0  第1张

1112.png 黄金分割线指标1.0  第2张

1113.png 黄金分割线指标1.0  第3张

斐波那契回调线也叫黄金分割线,在技术分析中经常使用,用来测算一段行情的理论幅度,以寻找相应的支撑和阻力。

黄金分割线是一种古老的数学方法,黄金分割的创始人是古希腊的毕达哥拉斯,他在当时十分有限的科学条件下大胆断言:一条线段的某一部分与另一部分之比,如果正好等于另一部分同整个线段的比即0.618,那么,这样比例会给人一种美感。后来,这一神奇的比例关系被古希腊著名哲学家、美学家柏拉图誉为“黄金分割律”。黄金分割线的神奇和魔力,在数学界上还没有明确定论,但它屡屡在实际中发挥着意想不到的作用。



下面是黄金分割线指标1.0结合缠论指标精简版5.0  http://www.dadaols.com/?id=486

2223.png 黄金分割线指标1.0  第4张

2222.png 黄金分割线指标1.0  第5张

2224.png 黄金分割线指标1.0  第6张


部分公式如下:

N1:6,NODRAW;


DRAWLINE1(CROSS(BACKSET(LOW<=LLV(LOW,5),BARSLAST( HIGH>=HHV(HIGH,5))+1),0.5),HIGH,CROSS(BACKSET(HIGH>=HHV(HIGH,5),BARSLAST( LOW<=LLV(LOW,5))+1),0.5),LOW,0);

DRAWLINE1(CROSS(BACKSET(LOW<=LLV(LOW,13),BARSLAST( HIGH>=HHV(HIGH,13))+1),0.5),HIGH,CROSS(BACKSET(HIGH>=HHV(HIGH,13),BARSLAST( LOW<=LLV(LOW,13))+1),0.5),LOW,0),COLORYELLOW;

DRAWLINE1(CROSS(BACKSET(LOW<=LLV(LOW,34),BARSLAST( HIGH>=HHV(HIGH,34))+1),0.5),HIGH,CROSS(BACKSET(HIGH>=HHV(HIGH,34),BARSLAST( LOW<=LLV(LOW,34))+1),0.5),LOW,0),COLORGREEN,LINETHICK2;

DRAWLINE1(CROSS(BACKSET(LOW<=LLV(LOW,55),BARSLAST( HIGH>=HHV(HIGH,55))+1),0.5),HIGH,CROSS(BACKSET(HIGH>=HHV(HIGH,55),BARSLAST( LOW<=LLV(LOW,55))+1),0.5),LOW,0),COLORRED,LINETHICK2;

DRAWLINE1(CROSS(BACKSET( HIGH>=HHV(HIGH,13),BARSLAST(LOW<=LLV(LOW,13))+1),0.5),LOW,CROSS(BACKSET( LOW<=LLV(LOW,13),BARSLAST(HIGH>=HHV(HIGH,13))+1),0.5),HIGH,0),COLORYELLOW;

DRAWLINE1(CROSS(BACKSET( HIGH>=HHV(HIGH,5),BARSLAST(LOW<=LLV(LOW,5))+1),0.5),LOW,CROSS(BACKSET( LOW<=LLV(LOW,5),BARSLAST(HIGH>=HHV(HIGH,5))+1),0.5),HIGH,0);

DRAWLINE1(CROSS(BACKSET( HIGH>=HHV(HIGH,34),BARSLAST(LOW<=LLV(LOW,34))+1),0.5),LOW,CROSS(BACKSET( LOW<=LLV(LOW,34),BARSLAST(HIGH>=HHV(HIGH,34))+1),0.5),HIGH,0),COLORGREEN,LINETHICK2;

DRAWLINE1(CROSS(BACKSET( HIGH>=HHV(HIGH,55),BARSLAST(LOW<=LLV(LOW,55))+1),0.5),LOW,CROSS(BACKSET( LOW<=LLV(LOW,55),BARSLAST(HIGH>=HHV(HIGH,55))+1),0.5),HIGH,0),COLORRED,LINETHICK2;


A:=(3*CLOSE+LOW+OPEN+HIGH)/6;

HH1:= IFELSE (H<REF(H,2)&&REF(H,1)<REF(H,2),REF(H,2),0);

LL1:= IFELSE (L>REF(L,2)&&REF(L,1)>REF(L,2),REF(L,2),0);

HH2:=VALUEWHEN(HH1>0,HH1);

LL2:=VALUEWHEN(LL1>0,LL1);

KA1:= IFELSE (CLOSE>HH2,-3,IFELSE(CLOSE<LL2,1,0));

KA2:=VALUEWHEN(KA1<>0,KA1);

HO:= HIGH >REF( HIGH,1) &&HIGH >REF(HIGH,2) && HIGH >=REFX(HIGH,1) && IFELSE(HIGH =REFX(HIGH,2), HIGH >REFX(HIGH,3), HIGH >REFX(HIGH,2));

FXH:=CROSS(HO,0.9);

HH:=REF(HIGH,BARSLAST(FXH));

LO:= LOW <REF(LOW,1) && LOW <REF(LOW,2) && LOW <=REFX(LOW,1) && IFELSE(LOW =REFX(LOW,2), LOW <REFX(LOW,3), LOW <REFX(LOW,2));

FXL:=CROSS(LO,0.9);

LL:=REF(LOW,BARSLAST(FXL));

STICKLINE(CLOSE,HH,HH-0.0001,COLORMAGENTA,0);

STICKLINE(CLOSE,LL,LL-0.0001,COLORLIGHTBLUE,0);

AUTOFILTER;



M:=7;//M值需要大于等于5

G:=MA(C,5);

D:=MA(C,10);

NNH:=BARSLAST(H=HHV(H,M)),NODRAW;

NNL:=BARSLAST(L=LLV(L,M)),NODRAW;

NN:=IF(REF(G,NNH)>REF(D,NNH) AND NNH<=M-3,NNH,IF(REF(G,NNL)<REF(D,NNL) AND NNL<=M-3,NNL,M-2)) ,NODRAW;

NNN:=IF(ISLASTBAR AND NN>0,NN,M-2) ,NODRAW;

H1:=REF(H,NNN)=HHV(H,M-1);

L1:=REF(L,NNN)=LLV(L,M-1);

FG01:=BACKSET(H1,NNN+1)>BACKSET(H1,NNN),NODRAW;//只设置前面第M-1个

FD01:=BACKSET(L1,NNN+1)>BACKSET(L1,NNN) ,NODRAW;

FG02:=FG01=FD01 AND G>D,NODRAW;

FD02:=FG01=FD01 AND G<D,NODRAW;

TTTT:=BARSLAST(FD01),NODRAW;

FG0:=FG01 AND IF(FG02=1,H=HHV(H,BARSLAST(REF(FD01,1))+1),H=HHV(H,IF(BARSLAST(L=LLV(L,M))>=M-2,M-2,BARSLAST(FD01)))) AND FD02=0 ,NODRAW;

FD0:=FD01 AND IF(FD02=1,L=LLV(L,BARSLAST(REF(FG01,1))+1),L=LLV(L,IF(BARSLAST(H=HHV(L,M))>=M-2,M-2,BARSLAST(FG01))))  AND FG02=0 ,NODRAW;

//高低点间周期

GT:=BARSLAST(FG0),NODRAW;

DT:=BARSLAST(FD0),NODRAW;

//第一次处理高低点间多余的点

LLLL:=DT=0 AND REF(DT,1)<GT AND L>REF(L,REF(DT,1)+1),NODRAW;

FG1:=BACKSET(REFX(GT,1)=0 AND GT<DT AND REFX(H,1)>=REF(H,GT),GT+1),NODRAW;

FD1:=BACKSET(REFX(DT,1)=0 AND DT<GT AND REFX(L,1)<=REF(L,DT),DT+1),NODRAW;

FG11:=IF(GT=0 AND REF(GT,1)<DT AND IF(REF(G,BARSLAST(L=LLV(L,M)))>REF(D,BARSLAST(L=LLV(L,M))),BARSLAST(L=LLV(L,M))<M-2,1) AND  H<REF(H,REF(GT,1)+1),1,0),NODRAW;

FD11:=IF(DT=0 AND REF(DT,1)<GT AND IF(REF(G,BARSLAST(H=HHV(H,M)))<REF(D,BARSLAST(H=HHV(H,M))),BARSLAST(H=HHV(H,M))<M-2,1) AND L>REF(L,REF(DT,1)+1),1,0),NODRAW;

//再次周期

GT1:=BARSLAST(FG11<>1 AND FG1<>1 AND FG0),NODRAW;

DT1:=BARSLAST(FD11<>1 AND FD1<>1 AND FD0),NODRAW;

FD2:=BACKSET(REFX(GT1,1)=0 AND DT1<3 AND GT1-DT1<4 AND REF(L,DT1)>LLV(L,GT1+M-2),DT1+1),NODRAW;

FG2A:=BACKSET(REFX(GT1,1)=0 AND DT1<3 AND GT1-DT1<4 AND REF(L,DT1)<=LLV(L,GT1+M-2) AND REF(H,GT1)>HHV(H,GT1+M-2

剩余50%内容付费后可查看
文章版权及转载声明

作者:大道老师本文地址:http://www.dadaols.com/?id=508发布于 5个月前 ( 02-26 )
文章转载或复制请以超链接形式并注明出处大道论市财经网

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

阅读
分享
双11

发表评论

快捷回复:

评论列表 (暂无评论,2936人围观)参与讨论

还没有评论,来说两句吧...